header-xh-01 header-xh-02 header-xh-03 header-xh-04 header-xh-05 header-xh-06 header-xh-07 header-xh-08 header-xh-09 header-xh-10 header-xh-11 header-xh-12 header-xh-13 header-xh-14 headerimage1 headerimage2 headerimage3 headerimage4 headerimage5 headerimage6
Sie sind hier: Startseite > Templates > klr-3col-flex > template.htm > Prüfung der Voraussetzungen
Letzte Bearbeitung:

Prüfung der Voraussetzungen

Das Template prüft einige Bedingungen, die erfüllt sein müssen, damit es funktionieren kann:

Das Plugin CnC (Cash des CMS) darf nicht aktiv sein, da im Template CSS-Formate enthalten sind, die unterschiedlich definiert sind, je nach dem ob sich die Seite im Editormodus befindet oder nicht.

if (is_readable($pth['folder']['plugins'].'cnc/index.php')) {
    die('Das Template <b>krl-3col-flex</b> ist in dieser Version nicht mehr mit dem Plugin CnC kompatibel.');
}

Laden der Java-Bibliothek:
// if jQuery4CMSimple is installed, include its jQuery library
if (is_readable($pth['folder']['plugins'].'jquery/jquery.inc.php')) {
    include_once $pth['folder']['plugins'].'jquery/jquery.inc.php';
    include_jQuery();
}

Überprüfen, ob das Plugin FA installiert ist.

// Plugin FA_XH
if (function_exists('fa_require')) {
    fa_require();
} else {
    echo '<p style="color: black; background-color: white;"></p>Das Template "krl-3col-flex" benötigt das Fa_XH-Plugin.<br>Das Fa_XH-Plugin kann hier heruntergeladen werden: <a href="https://github.com/cmb69/fa_xh/releases" target="_blank">Download</a><br>Installieren Sie das Plugin!</p>'."\n";
}

Überprüfen, ob das Plugin Morepagedata installiert ist.

// Plugin Morepagedata
if (!function_exists('getPageDataFields')) {
    echo '<p style="color: black; background-color: white;"></p>Das Template "krl-3col-flex" benötigt das Morepagedata-Plugin.<br>Das Morepagedata-Plugin kann hier heruntergeladen werden: <a href="https://github.com/cmsimple-xh/morepagedata/releases/" target="_blank">Download</a><br>Installieren Sie das Plugin!</p>'."\n";
}

Überprüfen, ob das Plugin Slideshow installiert ist.

// Plugin Slideshow
if ((!function_exists('slideshow')) and (!isset($NoSlideShow))) {
    echo '<p style="color: black; background-color: white;">Das Template "fhs-simple-all" benötigt das Slideshow-Plugin.<br>Das Slideshow-Plugin kann hier heruntergeladen werden: <a href="https://github.com/cmb69/slideshow_xh/releases/" target="_blank">Download</a><br>Installieren Sie das Plugin!</p>'."\n";
}
 


| Seitenanfang | |  - - - By CrazyStat - - -

Please activate JavaScript in your browser.

» Sitemap